Install with Node.js package manager (npm)
If you have not already installed version 4.2.0 or later of Node.js, install the latest Long Term Support (LTS) version.
cdto the root of your project and check if you have a
package.jsonfile. If you do not have the file, create it by running:
Install Dart Sass - version 1.0.0 or higher.
If you’re using Dart Sass 1.33.0 or greater, you may see deprecation warnings when compiling your Sass. You can silence deprecation warnings caused by dependencies if required.
Do not use either LibSass or Ruby Sass, which are deprecated, for new projects.
Although GOV.UK Frontend currently supports LibSass (version 3.3.0 and above) and Ruby Sass (version 3.4.0 and above), we will remove support in future. If you’re using either of these Sass compilers, you should migrate to Dart Sass as soon as you reasonably can.
Install GOV.UK Frontend
npm install govuk-frontend --save
When the installation finishes, the
govuk-frontend package will be in your